Jump to content

Photo

Windows 7 Installation/Game Problem


  • Please log in to reply
15 replies to this topic

#1
CapSpinzz

CapSpinzz

    Newbie

  • Members
  • Pip
  • 7 posts
So, I've actually been jumping in and out of MANY topics on this forum and finally just decided to ask for help the old fashioned way. HALP!! :3
(Going to provide as much info as possible)


Anyways - I've done this so far:

Putting d3drm.dll in system
also System 32
also game root

Installation fix using Extraction Tool

Compatibility Settings

Short Cut Parameters -best -fvf -debug -programmer (ect.)

Extracting all files from CD

Changing to 16 bit resolution - (this one harbors some results to an extent, but only the lego splash screen with no video, and nothing past that)

Windows Compatibility Tool Kit

Winodws XP Mode on 7 (Requires 7 Premium or higher, I'm running Home)

I've still gotten no where with getting this game to run, let alone just install. I'm running the game as admin and once I run it, I get a "Do you want to allow this program..." message, I hit ok, the box goes away. After that nothing. My task manager shows that its running but nothing actually happens.

So by using the extractor I can bypass the installer completely (of course) but then a new problem persists. Once I run the LegoRR.exe, I get the options window, but after hitting ok my screen will go into a black screen for about half a second then return to normal. No error message no nothing.

That's all the information I can think of that I've tried, and up to this point I'm completely stumped. So If I could get some help with this issue, it would be EXTREMELY appreciated!!! :)

#2
Phoenyx

You're doing the right thing overall, but there's a few things you may also want to try.

First off, windowed has fixed several installations without much effort. Try that. Of course you will need to switch your color resolution settings from the Windows control panel.

If you've already tried windowed mode, then you will either have to install the proper video codec or disable in-game videos. From what you've said, it's apparently crashing upon loading the intro video.

As for the "Do you want to allow this program...", it may be helpful to disable the so-called User Account Control. It really doesn't do anything except get in the way. Just my two cents.

#3
CapSpinzz

CapSpinzz

    Newbie

  • Members
  • Pip
  • 7 posts

You're doing the right thing overall, but there's a few things you may also want to try.

First off, windowed has fixed several installations without much effort. Try that. Of course you will need to switch your color resolution settings from the Windows control panel.


Did this, no go.

it's apparently crashing upon loading the intro video

Except when in windowed, it shows a box, has audio, but there's no video and crashes after the splash, like so:

Posted Image

As for the "Do you want to allow this program...", it may be helpful to disable the so-called User Account Control. It really doesn't do anything except get in the way. Just my two cents.

Did this also

#4
Cyrem

Cyrem

    Founder

  • Retired Administrators
  • PipPipPipPipPipPip
  • 3,796 posts
Did you try installing the video codec? http://rrubucket.s3....odec_490085.zip

Have you also tried (in the compatibility tab) disabling visual themes, enabling admin and set 640x480?

EDIT: Wait, it crashed AFTER the splash? The loading screen? or the LEGO Screen?

#5
CapSpinzz

CapSpinzz

    Newbie

  • Members
  • Pip
  • 7 posts
I'm attempting the codec now but the installer still won't run correctly. I can click it, it will try to run, then nothing. It shows in my task manager that it's running, but nothing is happening. Doing manual install under the read me.

- No go, did manual install, CMD accepted it, still no video but the audio is there.

I've tried almost ALL compatibility settings, including yours.
I'll give that one a try also.

- Also did not work, same result as above.

Well, under full screen it will crash even before the LEGO screen, in windowed I will hear the audio of the LEGO screen but no video. As soon as the audio is done (even before then) the game will become unresponsive and will stop after the LEGO screen completely.

#6
Cyrem

Cyrem

    Founder

  • Retired Administrators
  • PipPipPipPipPipPip
  • 3,796 posts
What graphics card are your running?

#7
Phoenyx

What graphics card are your running?


Seconded.

This could be important. LRR tends to have trouble on ATI cards (I personally got lucky), and even today some integrated cards aren't really designed for 3D graphics.

On another note, make sure your graphics card drivers are fully up to date.

#8
CapSpinzz

CapSpinzz

    Newbie

  • Members
  • Pip
  • 7 posts
Well luckily enough for me (I think), I'm using an Nvidia Geforce GT 520. Drivers fully updated regularly (including now)
Did a restart thinking maybe it would wipe out any existing issues that I might not have noticed but still, nothing.

Edit:
Would extracting the game to a different hard drive cause an issue like this? I have it:
Games HD F> Rock Raiders> Ect.

Instead of:

C:>Program Files (x86)>LEGO>Rock Raiders>Ect.

Edit 2: Also nothing, tried jumping it around and no change.

#9
Phoenyx

Strange... Sometimes the game just doesn't want to work.

Normally the path shouldn't matter (though it's not recommended to use either of the Program Files directories).

I guess you'll just have to disable in-game movies. I ended up having to do that myself.

#10
CapSpinzz

CapSpinzz

    Newbie

  • Members
  • Pip
  • 7 posts
Would be so kind as to link me to somewhere that tells me how to do this? :3

#11
Phoenyx

You'll have to open the WAD files to access lego.cfg (unless there's a command-line option?). http://www.rockraide...ads-or-10-wads/ This tells you how.

As for lego.cfg itself, there's a line that says DontPlayAvis FALSE. Change it to DontPlayAvis TRUE. Save it, then either repackage the WADs or put the contents of both into the Data folder, overwriting any conflicting files.

EDIT: I'm sorry if this seems like a pain to go through, but if the game is crashing at the intro and you have the codec installed, it's probably an issue with the video files themselves.

#12
JrMasterModelBuilder

JrMasterModelBuilder

    LR, LR2, LDR, and LDD Extractor Creator

  • Contributors
  • PipPipPipPip
  • 522 posts

You'll have to open the WAD files to access lego.cfg (unless there's a command-line option?). http://www.rockraide...ads-or-10-wads/ This tells you how.

As for lego.cfg itself, there's a line that says DontPlayAvis FALSE. Change it to DontPlayAvis TRUE. Save it, then either repackage the WADs or put the contents of both into the Data folder, overwriting any conflicting files.

EDIT: I'm sorry if this seems like a pain to go through, but if the game is crashing at the intro and you have the codec installed, it's probably an issue with the video files themselves.

I think just removing the video files will work.


As for the "Do you want to allow this program...", it may be helpful to disable the so-called User Account Control. It really doesn't do anything except get in the way. Just my two cents.

The UAC does a few things for security actually.

#13
Phoenyx


As for the "Do you want to allow this program...", it may be helpful to disable the so-called User Account Control. It really doesn't do anything except get in the way. Just my two cents.

The UAC does a few things for security actually.


Well, by the time it actually helps it's technically already too late. If programs are trying to start in administrator mode without you starting them, then your system is already compromised.

#14
CapSpinzz

CapSpinzz

    Newbie

  • Members
  • Pip
  • 7 posts
EDIT:

Ok, So it installed correctly. I can't get it to open up in full screen mode. However, after removing the video files and going into windowed mode under 16 bit, I'm now looking at the data design interactive screen with the sound of the first cut scene (the one with the asteroid hitting the ship) playing.
(I never noticed how long this cut scene really is)

And, nothing. After the cut scene audio is finished, it stops right there.

#15
CapSpinzz

CapSpinzz

    Newbie

  • Members
  • Pip
  • 7 posts
Cannot believe it. Found the fix for this absurd problem.
Install the K-Lite codec pack (basic)

Here >
http://codecguide.com/download_kl.htm

Switch to 16 bit mode under display settings
Right click desktop > Screen Resolution > Advanced Settings > Monitor > Colors - 16 bit

Run EXE under the installation folder, choose windowed mode.

For some reason, installing the codec that was provided above from Cyrem does not actually solve the problem.
Not sure why.

Looking at my childhood lego start menu screen now, amazing :)
Thanks for all the help guys!!!